Archive/Code_HackerRank

[HackerRank]Compare the Triplets

호리동 2018. 1. 17. 00:23

Alice and Bob each created one problem for HackerRank. A reviewer rates the two challenges, awarding points on a scale from  to  for three categories: problem clarityoriginality, and difficulty.

We define the rating for Alice's challenge to be the triplet , and the rating for Bob's challenge to be the triplet .

Your task is to find their comparison points by comparing  with  with , and  with .

  • If , then Alice is awarded  point.
  • If , then Bob is awarded  point.
  • If , then neither person receives a point.

Comparison points is the total points a person earned.

Given  and , can you compare the two challenges and print their respective comparison points?

Input Format

The first line contains  space-separated integers, , and , describing the respective values in triplet 
The second line contains  space-separated integers, , and , describing the respective values in triplet .

Constraints

Output Format

Print two space-separated integers denoting the respective comparison points earned by Alice and Bob.

Sample Input

5 6 7
3 6 10

Sample Output

1 1 

Explanation

In this example:

Now, let's compare each individual score:

  • , so Alice receives  point.
  • , so nobody receives a point.
  • , so Bob receives  point.

Alice's comparison score is , and Bob's comparison score is . Thus, we print 1 1 (Alice's comparison score followed by Bob's comparison score) on a single line.



1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
#include <bits/stdc++.h>
 
using namespace std;
 
vector < int > solve(int a0, int a1, int a2, int b0, int b1, int b2){
    // Complete this function
    vector<int> a;
    a.push_back(0);
    a.push_back(0);
 
    if(a0>b0)
        a[0]++;
    else if(a0<b0)
        a[1]++;
    
    if(a1>b1)
        a[0]++;
    else if(a1<b1)
        a[1]++;
    
    if(a2>b2)
        a[0]++;
    else if(a2<b2)
        a[1]++;
        
    return a;
        
    
}
 
int main() {
    int a0;
    int a1;
    int a2;
    cin >> a0 >> a1 >> a2;
    int b0;
    int b1;
    int b2;
    cin >> b0 >> b1 >> b2;
    vector < int > result = solve(a0, a1, a2, b0, b1, b2);
    for (ssize_t i = 0; i < result.size(); i++) {
        cout << result[i] << (i != result.size() - 1 ? " " : "");
    }
    cout << endl;
    
 
    return 0;
}
 
cs



Comment

모든 값을 각각의 변수로 받아주는 함수였기 때문에 이렇게 작성해서 각각 비교했는데.. 이래도 되는건가 싶긴 하다. 문제에서 요구하는 방식이 이런게 맞는건가?